• Seems like hotmail /outlook is blocking emails from here so please refrain from using one of these accounts as you may not receive your authorization email.. many thanks

BCusb can read s25fl128p but cant write pls help

jhaye knyt

New Member
hi to all i got my new blackcat last week and try to read the flash chip spi s25fl128p wson package

i desolder the chip on the board and try to read then successfull but i try to write what blackcat read on my chips its not succes always mismatches
 

D3m0n

Administrator
Staff member
How do you have the chip connected ? If your connection to the chip is incorrect (long wires) this could be your issue
 

jhaye knyt

New Member
i just solder the 6pin jumper wires included on the package and solder floppy cable wire length 10cm directly to the chips then the flash is detected
ok ill try to shorten the length of cable and post the results thanks for the advice
 

jhaye knyt

New Member
@d3mon i shorten the length of cable succesfully written according to blackat usb logs i use automatic settings

but i read the chips to check the if written correctly the chip is blank


try to use manual settings some files is writen but got too many mismatches

can u check if setting on manual is correct

thanks

 

Pantheon

Active Member
Developer
@jhaye: I have just tested a Spansion S25FL128P device with BCUSB (build 304 / SPI FW 1.09), the SOIC-16 package using the SPI socket adapter and it reads and programs 100% correctly. The write speed is around 160KB/s.

Therefore, I would assume your connection is not setup correctly. On the PCB board, you need to have 3.3v jumper on, and for the wiring, you should make sure VCC from BCUSB Pin 2 is connected to both HOLD# (pin 1) and VCC (pin2).

In addition, also make sure your GROUND (BCUSB pin1) is properly connected to the package.
 

jhaye knyt

New Member
thanks dude ill try to buy spi socket adapter this week maybe some itermitent signal if direct solder on chips
 

D3m0n

Administrator
Staff member
You dont necessarily need the adapter , however it does make the job a lot easier if you have lifted the chip.
Could you perhaps post a picture of how the device is connected so we have a better idea of any underlying issues .
 

jason

Member
demon tell me if i am wrong but if i remember correctly, you can skip the vcc connection to the board if you power the modem from its factory power supply. just plug it in and have all of your chip pins connected correctly.
 

D3m0n

Administrator
Staff member
Correct , but in order to do that (using the modem power supply) you need to have the correct ISP point on the modem.
 

jhaye knyt

New Member
im using pcb1.8 i follow all diagram and the chips identify correctyl and jedec id is correct thats no problem on wiring etc...

it works now what i do is let blackcat read the flash then it became ffffff or blank it means programming by automatic it will erase the the whole flash chips this im wondering why

then do a manual configuration see the pictures posted above got correct id then do flashing after finish writing by manual configuration try to read using blackat automatics settings and manual setting then do compare to the source

100% matches

ill use 3.3v and ground from bcusb directly solder to chips
 

Braza

New Member
Could you please send me a screen with the manual settings s25fl128p SPI, I try to write manually.
 

D3m0n

Administrator
Staff member
Set your BCUSB to 5v and set both your dip switches to the ON position and try to program the chip like that . Let me know the result.
 

Braza

New Member
Hi..
The 321 program version . I cannot write S25fl129p, only read.

I try to write and this wrtite only 00 00 00 ...

I can write and read with sucess in version 282.​
 

D3m0n

Administrator
Staff member
Ok on Build321 what version of the firmware are you using is it 3.01 or 2.02 ?
 

Braza

New Member
BCUSB.1.09.SPI.hex .
After update is neede to restart the PC , to write SPI in 100%.
 

D3m0n

Administrator
Staff member
Ok so on build 282 with firmware 1.09 it reas and writes 100%
With build 282 with firmware 2.02 it does not detect the flash ?
with build 321 with firmware 2.02 it does not detect the flash ?
With build 321 with firmware 3.01 it detects the flash but does not write ?

Is this correct ?
 
Top