• Seems like hotmail /outlook is blocking emails from here so please refrain from using one of these accounts as you may not receive your authorization email.. many thanks

Is Embedded Computers still in business? Need support.

Fathom500

New Member
We have an issue with 2.2 boards not recognizing a device. We have been using the 2.1 boards for quite some time and they work fine. We purchased 6 of the new boards and have an issue with them not recognizing any part from CSI (On Semi/Catalyst). The old boards recognize these parts without issue. They also recognize every other part we have tried The new boards work with every chip we have tried except the CSI chips. These are simple i2C Eeproms. So far in an attempt to get support I have done the following:

Filled out the support form on the website 2 times – No response in over 2 weeks.
2. Sent email to address that was provided from past support – No response in over a week.
3. Posted the issue on the Flashcat forum – It’s been read over 30 times – No response.
4. Posted a bad review on the Amazon product site detailing the issue – Recent
5. Sent a question through the Amazon site to the folks that sold them to us – Recent

At this point I don't know what else to do to get support. I would rather not have to return these boards but if I cannot get some type of support/response then I will have no choice but to return them.
 

Pantheon

Active Member
Developer
2. Check your spam folder. I confirmed you were sent an email within 12 hours.
3. Admins of this site saw your post and began internal discussions of your issue.
4. Why would you expect us to help you if you first leave negative reviews for a product we all love and work on?
5. Amazon/eBay/etc. are third parties, they only sell the products.

And to respond: this week we acquired a CAT24C03WI and have confirmed the issue you reported and a hardware engineer is taking a look at it.

20190529_235611.jpg
 

Fathom500

New Member
2. Check your spam folder. I confirmed you were sent an email within 12 hours.
3. Admins of this site saw your post and began internal discussions of your issue.
4. Why would you expect us to help you if you first leave negative reviews for a product we all love and work on?
5. Amazon/eBay/etc. are third parties, they only sell the products.

And to respond: this week we acquired a CAT24C03WI and have confirmed the issue you reported and a hardware engineer is taking a look at it.

View attachment 1212
Thank you for taking a look. I've been checking the spam bucket. Nothing there. No worries. Maybe lost in the ether somewhere. Review was not really negative on the product. It was more just asking what happened to support. I like the product. My students like the product. We will post a glowing review once we get the new version working with these components. My apologies if I came off overly harsh.

I have test boards with both parts installed. I also have access to o-scopes with i2c decoders so if you need to to capture any traces of i2c signals just let me know. Happy to assist. I can PM you my email and cell number if you like.
 

Fathom500

New Member
Thank you for taking a look. I've been checking the spam bucket. Nothing there. No worries. Maybe lost in the ether somewhere. Review was not really negative on the product. It was more just asking what happened to support. I like the product. My students like the product. We will post a glowing review once we get the new version working with these components. My apologies if I came off overly harsh.

I have test boards with both parts installed. I also have access to o-scopes with i2c decoders so if you need to to capture any traces of i2c signals just let me know. Happy to assist. I can PM you my email and cell number if you like.
We were also going to cycle through the iterations of the FW/driver/software/PCB to see if we could find out where exactly it stopped working. Do you see any value in that or should we just wait for you guys to investigate?
 

Pantheon

Active Member
Developer
No need, a qualified EE is looking at it. Also, please clarify what you mean by "My students". Thanks.
 

Fathom500

New Member
No need, a qualified EE is looking at it. Also, please clarify what you mean by "My students". Thanks.
I sometimes bring my Flashcat 2.1 boards(as well as some other tools) into a FW development class I teach from time to time. Mostly for show and tell. It always generates a lot of interest in the boards. I only owned 2 boards and they were getting passed around a lot so I bought some more of the new boards to use in class to save wear and tear on the few boards I have. The number 1 question I get when I do this is "where can I buy one of those?".
 

ricktendo

Member
Main website embeddedcomputers.net has all the latest software, boards and adapters

Note: Moving forward with the latest software you may require you obtain a license (no worries its free for Educational)

 
Last edited:

Pantheon

Active Member
Developer
ricktendo is correct. You should register the software for educational use.

P.S. I should have an update tonight on this I2C issue.
 

Pantheon

Active Member
Developer
i2c_result.jpg

3rd line, at the end, you can see it floating at 2.3V~. Probably the resistor (4.7K) is too strong. Maybe changing this to 10K or even 22K may fix the issue. I'll test tomorrow to confirm.
 

Pantheon

Active Member
Developer
Eng. test completed.

This device is detected and works correctly using FCUSB Pro:

CAT24C04WI_FCUSBPRO.jpg

However, this is the same result on Classic:

CAT24C04WI_FCUSBCLASSIC.jpg

Slave device holds down line from 3.3V to only 2.4V.

The conclusion, is that we think the SDA/SCL lines on Classic use totem-pole arranged transistors and that causes the I2C slave device to behave differently. Timing wise, its nearly exact to FCUSB Pro (which uses a CPLD for I2C master).

Thus, I don't think this can be fixed in firmware.

So you can: 1) contact EC and arrange to have one or more units upgraded to Pro. 2) wait 2 weeks and I will see if a hardware modification to add open-drain will work (it should).
 

Fathom500

New Member
Eng. test completed.

This device is detected and works correctly using FCUSB Pro:

View attachment 1216

However, this is the same result on Classic:

View attachment 1215

Slave device holds down line from 3.3V to only 2.4V.

The conclusion, is that we think the SDA/SCL lines on Classic use totem-pole arranged transistors and that causes the I2C slave device to behave differently. Timing wise, its nearly exact to FCUSB Pro (which uses a CPLD for I2C master).

Thus, I don't think this can be fixed in firmware.

So you can: 1) contact EC and arrange to have one or more units upgraded to Pro. 2) wait 2 weeks and I will see if a hardware modification to add open-drain will work (it should).
Thanks for the update.

The company I bought them from on Amazon told me to contact EC and that they will swap out all 6 units for the pro version.
However the contact email address at Embedded keeps getting stripped out by Amazons filtering.

Can you provide me with a contact email address at Embedded? Supposedly they are expecting a message from me. But I don't have the address.

Thanks again.
 

Pantheon

Active Member
Developer
email is contact at embeddedcomputers.net

Also, the CAT24C03WI is clearly not a "drop-in" replacement for the classic Atmel EEPROM. Support for these chips were added a long time ago and everything worked as designed, but these new run chips clearly left out something.
 

Fathom500

New Member
Eng. test completed.

This device is detected and works correctly using FCUSB Pro:

View attachment 1216

However, this is the same result on Classic:

View attachment 1215

Slave device holds down line from 3.3V to only 2.4V.

The conclusion, is that we think the SDA/SCL lines on Classic use totem-pole arranged transistors and that causes the I2C slave device to behave differently. Timing wise, its nearly exact to FCUSB Pro (which uses a CPLD for I2C master).

Thus, I don't think this can be fixed in firmware.

So you can: 1) contact EC and arrange to have one or more units upgraded to Pro. 2) wait 2 weeks and I will see if a hardware modification to add open-drain will work (it should).
Will the HW change be a BOM change (something I can rework in the lab to save time and shipping cost)? Or a BOM and artwork change?
 

Pantheon

Active Member
Developer
New PCB revision with ATMEGA32U4 and firmware that utilizes the TWI interface pins.
 

Fathom500

New Member
Is the Flashcat 2.3 board still on track to be released next week? We are trying to decide whether to wait for it or upgrade a unit or 2 to pro. We prefer to wait for 2.3 however it it is delayed we would want to upgrade to Pro on just a few units.
 

ricktendo

Member
Is the Flashcat 2.3 board still on track to be released next week? We are trying to decide whether to wait for it or upgrade a unit or 2 to pro. We prefer to wait for 2.3 however it it is delayed we would want to upgrade to Pro on just a few units.
The Pro is also getting a new revision, you will have to wait anyhow.
 
Top