• Seems like hotmail /outlook is blocking emails from here so please refrain from using one of these accounts as you may not receive your authorization email.. many thanks

Adapter bga24 mach1 Winbond 25Q64FVBIG does not detect, help!

arrobazo

New Member
A week ago I bought 2 adapters for mach1 bga24 and bg63, today I have it in my hands and I tried the bga63 and I had no problems all right ...

When testing bga24 5x5ball "Winbond 25Q64FVBIG" but not recognizing it, I tried 3 different SPI without success. Now my question is!
it's compatible ? It's the only 5x5ball spi I have.


help the people of www.embeddedcomputers


I leave videos and photos

https://drive.google.com/open?id=1-CJTQabjHqvG323sAmn9RnehaGWEuLbi
 
Last edited:

Pantheon

Active Member
Developer
The flash chip needs to be reballed. Its a BGA adapter, not a LGA adapter.
 

arrobazo

New Member
The flash chip needs to be reballed. Its a BGA adapter, not a LGA adapter.
sure because the bga63 adapter is the same and I detect it without problems are not supposed that these sockets are used for memory with or without balls? ...

you have the datasheet or brand / model of the socket of both bga24 & bga63

Thank you!
 

Pantheon

Active Member
Developer
All BGA sockets are intended to be used with chips with solder balls.
 

arrobazo

New Member
All BGA sockets are intended to be used with chips with solder balls.
I will have to wait for my tin balls to arrive this week, another doubt I have 2 <FCUSB MACH1, pcb 2.0 and 2.1 on pcb2.0 I cannot detect a bga63 but if I change the socket to pcb 2.1 it detects the same bga63 perfectly attached the console text sw build 585 and video

https://drive.google.com/open?id=1xDfYb1ivmTU3lFnCJMoeTRlRS-_G-oKB

Code:
Connected to FlashcatUSB Mach¹, firmware version: 2.12
Voltage set to: 3.3V
FlashcatUSB Mach¹ SPI in-circuit programming enabled
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
NAND clock speed set to: 20MHz
Mode FWH returned ident code: 0x00002C00F1
Flash device not detected in Extension I/O mode

Code:
Connected to FlashcatUSB Mach¹, firmware version: 2.12
Voltage set to: 3.3V
FlashcatUSB Mach¹ SPI in-circuit programming enabled
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
NAND clock speed set to: 20MHz
Mode NAND X8 ASYNC returned ident code: 0x2CF1809504
Successfully detected device in NAND mode
Connected to Flash (CHIP ID: 0x2CF1809504)
Flash detected: Micron MT29F1G08ABAEA (134.217.728 bytes)
Programming mode: EXT I/O (Parallel)
Flash page size: 2.048 bytes (64 bytes extended)
Block size: 131.072 bytes
Device interface: NAND (X8 3.3V)
NAND block manager disabled
NAND memory map complete: 65.536 pages available for access
 

arrobazo

New Member
I managed to read bga24 5x5 by welding the balls, but it reads corrupt and does not record well when verifying it gives error! will I miss some setting for mach1?
(I bought an unofficial adapter for bga24 + fcusb Pro4.0 I write them without problems, in 5x5 and 6x4 ball formats)

https://i.gyazo.com/5549559cb950796134857d6807208c13.png

about the bga63 adapter, it only recognizes me in mach1 pcb2.1 as I said before it is already 2 mach1 pcb2.0 where I try them and today I solder tin balls without positive results.

which can answer me since the messages to embeddedcomputers do not answer them yet! some help !








https://translate.google.com/community?source=mfooter
 

Pantheon

Active Member
Developer
So problem 1: PCB 2.0 does not detect BGA-63 (NAND DEVICE), but PCB 2.1 does.

I do not know why, could be logic issue? If so, do this from the console:

load.logic

Which will re-program the FPGA with the current logic code.
 

Pantheon

Active Member
Developer
Problem 2: MACH1 with BGA-24 adapter has problems with W25Q64 (5x5 ball).

Please post the console for the detect event.
 

Pantheon

Active Member
Developer
Also, confirm the entire part number for the Winbond deivce (i.e. W25Q64JVTBIQ)
 

arrobazo

New Member
Problem 2: MACH1 with BGA-24 adapter has problems with W25Q64 (5x5 ball).

Please post the console for the detect event.
Code:
Disconnected from FlashcatUSB Mach¹ device
Connected to FlashcatUSB Mach¹, firmware version: 2.12
Voltage set to: 3.3V
FlashcatUSB Mach¹ SPI in-circuit programming enabled
Attempting to detect SPI device in SPI extended mode
SQI clock set to: 10 MHz
Successfully opened device in SQI mode
Connected to SQI Flash (RDID:0xEF4017)
Flash detected: Winbond W25Q64 (8.388.608 bytes)
Programming mode: SQI (SPI-QUAD)
Detected Flash in SPI mode (1-bit)
Entering QPI mode for Winbond device
Error: failed to set the QE bit
Detected SPI Flash on SQI port
 

arrobazo

New Member
So problem 1: PCB 2.0 does not detect BGA-63 (NAND DEVICE), but PCB 2.1 does.

load.logic

Which will re-program the FPGA with the current logic code.
I do not know why, could be logic issue? If so, do this from the console:

Code:
FlashcatUSB Script Engine build: 306
Welcome to the FlashcatUSB interfacing software, build: 585
LibUsbDotNet version: 2.2.8.104
Running on: Microsoft Windows 10 Pro (64 bit)
Serial NOR memory database loaded: 387 devices supported
Serial NAND database loaded: 35 devices supported
Parallel NOR memory database loaded: 307 devices supported
Parallel NAND memory database loaded: 165 devices supported
OTP/UV EPROM memory database loaded: 16 devices supported
Connected to FlashcatUSB Mach¹, firmware version: 2.12
Voltage set to: 3.3V
FlashcatUSB Mach¹ SPI in-circuit programming enabled
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
NAND clock speed set to: 20MHz
Mode FWH returned ident code: 0x00002C00F1
Flash device not detected in Extension I/O mode
Voltage set to: 3.3V
FlashcatUSB Mach¹ SPI in-circuit programming enabled
Programming FPGA with bitstream (32109 bytes)
FPGA device successfully programmed
Connected to FlashcatUSB Mach¹, firmware version: 2.12
Voltage set to: 3.3V
FlashcatUSB Mach¹ SPI in-circuit programming enabled
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
NAND clock speed set to: 20MHz
Mode FWH returned ident code: 0x00002C00F1
Flash device not detected in Extension I/O mode
 

Pantheon

Active Member
Developer
Thank you arrobazo. I think issue might be with firmware/software for this chip in this mode. I ordered a 25Q64FVBIG overnight and will test it THR. It should be similar to W25Q64FV (which is obsolete and not available for order)l.
 

Pantheon

Active Member
Developer
Problem 1:
Does PCB 2.0 detect any NAND device? That is, did you try a TSOP48 adapter (Type-B / NAND) and does that detect?
 

Pantheon

Active Member
Developer
No, I want you to try the TSOP48 adapter that came with either PCB 2.0 or 2.1.
 

Pantheon

Active Member
Developer
Problem 1: after many considerations, I do not know your problem. Please arrange to send back PCB 2.0 for exchange to PCB 2.1.

Problem 2: SPI / SQI mode for MACH1 has firmware bug for 3-byte address devices (i.e. W25Q64). Software update coming this weekend to address/fix issue.
 

arrobazo

New Member
Problem 1: after many considerations, I do not know your problem. Please arrange to send back PCB 2.0 for exchange to PCB 2.1.
How do I send you both fcusb Mach1 2.0?

I live in South America Chile .. bga adapters for mach1 are not supposed to be available before pcb2.1, could you prove if the same thing happens with pcb2.0? or are they just my 2 mach1 2.0 and is it an isolated problem?

I say because if it is a problem of hw to say an example the people who buy that bga63adapter and have mach1 2.0 would be forced to change their mach1 2.1

Problem 2: SPI / SQI mode for MACH1 has firmware bug for 3-byte address devices (i.e. W25Q64). Software update coming this weekend to address/fix issue.
ok, well as I told you I had to buy another adapter to get out of the problem
the spi are 6x4mm which I am rewriting, when will the bga24 6x4 be available for mach1? because I bought the 5x5mm without realizing that detail and I really won't use it
 
Top