• Seems like hotmail /outlook is blocking emails from here so please refrain from using one of these accounts as you may not receive your authorization email.. many thanks

Flash memory detected but not found in flash library

cosmic

New Member
I purchased a 'voultar' special. Got TSOP-48 (NOR x8) and TSOP-48 (NOR).

Running FlashcatUSB in Parallel NOR/NAND mode, get the error "Flash memory detected but not found in flash library"

Flash memory is 29F800 TSSOP48

Thought maybe a USB issue, tried 3 different cables on 2 different ports with the same results. The other 2 flash memory modules I have give the same error message in Flashcat. Unable to flash.
 

cosmic

New Member
It doesn't look like you can edit post (or my account is too new) but it was purchased from here - https://www.embeddedcomputers.net/products/Voultar/

According to the website bundle includes:
FlashcatUSB XPORT parallel programmer
TSOP48 NOR (X16 TYPE-A) Socket
TSOP48 NOR (X8 ONLY) Socket

Now I did get
FlashcatUSB XPORT parallel programmer
TSOP-48 (NOR x8) Socket
TSOP-48 (NOR) Socket

So I'm not sure if that could be the problem, maybe I was mailed the wrong socket on accident?

The steps performed were
Insert socket into programmer
Insert memory into socket
Installed drivers, successful (Windows 10)
Plugged in programmer to USB plug.
Opened FlashCatUSB
Switched to Parallel NOR/NAND mode
Pressed F1 and got the error.

Tried two other flash memory modules to rule out any errors. Also tried two other USB cables (three total) on two different ports. Also, the product description shows it comes with a USB cable but I wasn't supplied one.

This is the first time I'm using this unit and program so if I'm missing something, please let me know. Thanks.
 

Attachments

Pantheon

Active Member
Developer
Hi Cosmic, please tell me the full part number of the 29F800. Also, copy and paste the text from the console window.
 

cosmic

New Member
Hi Cosmic, please tell me the full part number of the 29F800. Also, copy and paste the text from the console window.
29F800 / 29F016

FlashcatUSB Script Engine build: 300
Welcome to the FlashcatUSB interfacing software, build: 570
LibUsbDotNet version: 2.2.8.104
Running on: Microsoft Windows 10 Enterprise (64 bit)
Serial NOR memory database loaded: 369 devices supported
Serial NAND database loaded: 28 devices supported
Parallel NOR memory (x8/x16) database loaded: 296 devices supported
SLC NAND memory (x8) database loaded: 139 devices supported
Connected to FlashcatUSB xPort, firmware version: 4.45
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NAND X8 returned ident code: 0xAAA2AAAAAA
Mode NOR X16 (Type-2) returned ident code: 0xAAFFAAFFFF
Mode NOR X16 (Type-1) returned ident code: 0xAA00AA0000
Mode NOR X8 (Type-1) returned ident code: 0xAA00AA0000
Mode NOR X8 (Type-2) returned ident code: 0xAA00AA0000
Mode FWH returned ident code: 0x0000000000
Connected to Flash (CHIP ID: 0xAA00AA0000)
For device support email contact@embeddedcomputers.net with the CHIP ID
 

Pantheon

Active Member
Developer
I need to see the FULL part number. Also a picture of how you have it connected please.
 

hippie131

New Member
I have the same issue as cosmic. Attaching a pic of how everything is connected. I tried 4 different 29f800BA-70PFTN modules. 2 of them give me this output:

Attempting to automatically detect Flash device
Flash device not detected in Extension I/O mode

The other 2 seem to be detected as memory and give different ID numbers:

Chip A)
Mode NAND X8 returned ident code: 0xAEAEAEAEAE
Mode NOR X16 (Word addressing) returned ident code: 0xAEFFAEFFFF
Mode NOR X16 (Byte addressing) returned ident code: 0xAEFFAEFFFF
Mode NOR X8 returned ident code: 0xAE00AEFFFF
Connected to Flash (CHIP ID: 0xAE00AEFFFF)

Chip B)
Mode NOR X16 (Word addressing) returned ident code: 0xAAFFAAFFFF
Mode NOR X16 (Byte addressing) returned ident code: 0xAAFFAAFFFF
Mode NOR X8 returned ident code: 0xAA00AAFFFF
Connected to Flash (CHIP ID: 0xAA00AAFFFF)

Chip A and B both give a final error of
flash memory detected but not found in flash library.
 

Attachments

hippie131

New Member
Tried it again with the x16 module (i got the X8 and X16 one as I wasn't sure which I needed). Here is the full console output if that's needed. Same chip both times:

FlashcatUSB Script Engine build: 302
Welcome to the FlashcatUSB interfacing software, build: 576
LibUsbDotNet version: 2.2.8.104
Running on: Microsoft Windows 10 Pro (64 bit)
Serial NOR memory database loaded: 376 devices supported
Serial NAND database loaded: 35 devices supported
Parallel NOR memory database loaded: 305 devices supported
Parallel NAND memory database loaded: 152 devices supported
OTP/UV EPROM memory database loaded: 16 devices supported
Connected to FlashcatUSB XPORT, firmware version: 5.04
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NOR X8 returned ident code: 0x000005004C
Mode FWH returned ident code: 0xC000C00000
Connected to Flash (CHIP ID: 0xC000C00000)
For device support email contact@embeddedcomputers.net with the DEVICE ID
Disconnected from FlashcatUSB Classic device
Connected to FlashcatUSB XPORT, firmware version: 5.04
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NAND X8 returned ident code: 0xAEAEAEAEAE
Mode NOR X16 (Word addressing) returned ident code: 0xAAFFAAFFFF
Mode NOR X16 (Byte addressing) returned ident code: 0xAAFFAAFFFF
Mode NOR X8 returned ident code: 0xAA00AAFFFF
Connected to Flash (CHIP ID: 0xAA00AAFFFF)
For device support email contact@embeddedcomputers.net with the DEVICE ID
Connected to FlashcatUSB XPORT, firmware version: 5.04
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NAND X8 returned ident code: 0xAAAAAAAAAA
Mode NOR X16 (Word addressing) returned ident code: 0xAAFFAAFFFF
Mode NOR X16 (Byte addressing) returned ident code: 0xAAFFAAFFFF
Mode NOR X8 returned ident code: 0xAA00AAFFFF
Connected to Flash (CHIP ID: 0xAA00AAFFFF)
For device support email contact@embeddedcomputers.net with the DEVICE ID
 

Pantheon

Active Member
Developer
1) Download the newest software, it has some changes.
2) Set DIP to 5V
3) Use X16 adapter.

Report back.
 

lanyap

New Member
I'm having the same 'Flash memory detected but not found in Flash library' problems as cosmic and hippie131 as well. Using Fujitsu 29F800BA-90PFTN chips; here is the text from the Console window:

FlashcatUSB Script Engine build: 302
Welcome to the FlashcatUSB interfacing software, build: 577
LibUsbDotNet version: 2.2.8.104
Running on: Microsoft Windows 10 Home (64 bit)
Serial NOR memory database loaded: 385 devices supported
Serial NAND database loaded: 35 devices supported
Parallel NOR memory database loaded: 305 devices supported
Parallel NAND memory database loaded: 159 devices supported
OTP/UV EPROM memory database loaded: 16 devices supported
Connected to FlashcatUSB XPORT, firmware version: 5.05
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NAND X8 returned ident code: 0x0101010101
Mode NOR X16 (Word addressing) returned ident code: 0x010171A31D
Mode NOR X16 (Byte addressing) returned ident code: 0x0100A3A3A3
Mode NOR X8 returned ident code: 0x01000101FD
Connected to Flash (CHIP ID: 0x01000101FD)
Common Flash Interface information not present
For device support email contact@embeddedcomputers.net with the DEVICE ID
 

Attachments

GenjiHarvester

New Member
I have pretty much the same issue with the xPort (the newer version via the Voultar bundle) as reported in the above post. This is the report for the x16:
Connected to FlashcatUSB XPORT, firmware version: 5.06
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NAND X8 returned ident code: 0xF7F7F7F7F7
Mode NOR X16 (Word addressing) returned ident code: 0xF7F7F7F7F7
Mode NOR X16 (Byte addressing) returned ident code: 0xF7F7F7F7F7
Mode NOR X8 returned ident code: 0xF700F7F7F7
Connected to Flash (CHIP ID: 0xF700F7F7F7)
Common Flash Interface information not present
For device support email contact@embeddedcomputers.net with the DEVICE ID

And the x8:

Connected to FlashcatUSB XPORT, firmware version: 5.06
Firmware features supported: SPI, I2C, EXTIO
Initializing EXT I/O hardware board
EXT I/O board successfully initialized
Attempting to automatically detect Flash device
Mode NAND X8 returned ident code: 0x7878787878
Mode NOR X16 (Word addressing) returned ident code: 0x01FFAD0000
Mode NOR X16 (Byte addressing) returned ident code: 0x01FF000100
Mode NOR X8 returned ident code: 0x0100AD0000
Successfully detected device in NOR X8 mode
Connected to Flash (CHIP ID: 0x0100AD0000)
Common Flash Interface information not present
Flash detected: AMD AM29F016B (2,097,152 bytes)
Programming mode: EXT I/O (Parallel)
Device interface: NOR X8 (5V)
Write mode supported: Standard

Even though it seems to detect the x8 (with an AM29F016B chip loaded), I cannot write past a certain block without verification failure. This is on multiple computers, etc., as mentioned in the other thread.
 

riseinside

New Member
hello im having the same issue purchased the voultar special its recognising that their is a flash device connected but is saying its not in the library
 
Top