• Visit https://www.embeddedcomputers.net/ for Hardware; Software and all other things related to FlashcatUSB

Official BCUSB RC13 release

No Offence taken ... It would of been irrelevant depending on what programmer you bought , as you would of had to make up different leads for them as well , as they all come with a standard ejtag layout , and as you have noticed a lot of modems differ from the norm. The bcusb was designed to be straight forward so to speak , but as with a lot of things it just does not work perfectly for some as they would like. With the full dumps in this thread , when you load them do you still get the verification error at 0x80000 or is it only when you try to load a firmware image ?

I can't remember if I tested the dump you provided but I know the dump I uploaded for the PDC2100 has those same errors. I used the Script that you uploaded that allows me to flash haxoware and it just freezes on the 192.168.100.1 screen after flash. So I don't know what that all means.

I'll do some more flashes and post the firmwares used and the corresponding logs so you'll have a better Idea what I'm going through. I just don't have them with me right now I'll have to wait to later today.
 
Well I did some flashing and saved the logs and uploaded the files I used each time so you could give me some advice on what to do. Take a look I hope to hear back from you soon. Thanks D3mOn.
 

Attachments

  • 1st Flash.zip
    1.1 MB · Views: 67
  • 2nd Flash.zip
    1.1 MB · Views: 66
  • 3rd flash.zip
    1.8 MB · Views: 62
  • 4th Flash.zip
    1.1 MB · Views: 66
  • 5th Flash.zip
    2 MB · Views: 63
  • 6th Flash.zip
    1.7 MB · Views: 59
  • Flash back to OEM - Unbrick.zip
    1.8 MB · Views: 65
  • Read me.txt
    1.4 KB · Views: 68
Right looking at the logs in the attachments there are loads of mismatches , this could well be the delay setting we need to alter ,, but 1 thing i want to check , on the 4th Flash you say you got it to see your pc and the hardware wizard popped up , Is it possable for you to connect to your pc using the RJ45 connector instead of the USB ? this way we can solve the firmware issues first and then revert to the usb driver issue ,, due to it being if you load Hax onto the modem you will have to load SB510x usb drivers and not DPC drivers.

For now as well lets just work on 2MB dumps , using the main flash tab , this will help us pin point specific errors , once we can safely get the modem back to stock firmware , we can work on getting Hax loaded.

On the script that i posted here change these parameters to this

SetParam(2,500)
SetParam(3,500)

and see if you get any mismatches on full dump write
 
Thanks for the help D3mOn!

Ok I think I understand what you mean when you say the HAX firmware will need to load the 510X usb drivers to get recognized by my pc instead it's trying to load DPC2100 usb drivers. But then I'm not sure if that's what you mean.

I changed the DPC2100.bcs to SetParam(2,500) and SetParam(3,500). Then instead of the Webstar DPC2100 tab I used the Flash tab to write the 2mb dump I have available (it was DL'ed off the net somewhere). there were mismatches though. The Modem acts as is it's working and all lights appear to work and the PC recognizes it. The hardware wizard doesn't appear because it's been previously installed I assume. But it shows up right when I plug the USB cable to the modem.

I'm not sure what you mean about the RJ45 cable though...? I don't have any serial or com ports on my motherboard that's why I bought the BlackCatUSB in the first place.

I included the files I used with a log for this last Flash:
 

Attachments

  • Flash back to OEM - Unbrick.zip
    1.8 MB · Views: 70
RJ45 is for the ethernet port on the modem/pc , basically elimanating use of the usb . Can you access the 192 gui of the modem on pc ? If so does it show the stock firmware ?
 
Well I noticed on my modem itself it says: SA-DPC2100
v202-r1242
-040825a

and when I load up blackcat and view under the webstar PDC2100 tab it says current firmware is: epc2100r2-v202r1256-070601c.bin. Does this matter?

I did plug the modem directly into my PC and tried to load the 192.168.100.1 page and it will not load. I used a cat5/RJ45 direclty to my ethernet card. But I think the USB works just fine.
 
epc is euro docsis , it should not really matter , do you have a full dpc dump you can load to test ? It seems the firmware is being detected correctly so it has written itself to the modem , to simplify things as well un-tick the verify flash on the main window , lets see if we can get the modem to load the gui , so we will not worry about mismatches at this point.

When you goto the 192 page , does it time out ? or does it load and just a blank page ?
 
I reflashed with the same files in the last post using the flash tab and firstly unchecked the verify box.

Here's a link that has all the DPC 2100 related firmwares I have: http://www.megaupload.com/?d=ZVWB0TZH

I never backed the firmware up I used the method that allows you to flash though the ethernet cable originally which didn't work.

When trying to access the 192.168.100.1 page it shows some broken images that would appear to be the layout. It hangs and doesn't appear to time out.
 
Try this full flash
 

Attachments

  • DPC2100_Full.rar
    937.7 KB · Views: 71
Right now get the correct haxorware image and load it via the modded firmware tab on the DPC script , and do a write to the modem , then once loaded check 192 page see if you have Hax.
 
I have just loaded this one , LED's seem weird but it goes to 192 page no problem , give it a try and see how it works on yours.

EDIT: Seems we have the same firmware in mind
 

Attachments

  • haxorware11rev39-DIAG.rar
    1.1 MB · Views: 70
Not really, verify is better on , as it gives you a proper indication as to any issues , but as i kind of noticed the issue here was the firmware itself , so in order to stop seeing the mismatches , i asked for it to be turned off ,,, hopefully once you have Hax loaded and working and BACKED UP, you can test this out by turning verify on and loading your new dump and see if you have the mismatch erros
 
Ok I flashed it but the Modem won't recognize wizard shows but won't install. do I need 510X usb drivers?

The lights all work except the cable light but I don't have that hooked up.
 
Yes , it will be some form of SB5X drivers as hax is based on moto firm , can you verify if it works via ethernet
 
Hey man thanks for your help I finally got haxoware installed and running man what a pain but it seems so easy now.
 
Nice one , just make sure you keep the backup's that worked for you , that way you know if anything goes wrong you have them to restore with.
 
Back
Top